CSCR-069 Rename various ActClassContainer codes
Editing of Change Requests is restricted to the submitter and the co-chairs of the Clinical Statement Project. Other changes will be undone. Please add comments to the "discussion" page associated with this Change Request.
Back to Clinical Statement Change Requests page.
|Submitted by: Bob Dolin||Revision date: Sept 30, 2006|
|Submitted date: Sept 30, 2006||Change request ID: CSCR-069|
The use and meaning of “entry” and “organizer” is not consistent across CDA, Clinical Statement, and the ActClassContainer hierarchy. The intent of this proposal is to realign the various usages. No changes are needed to definitions or to the ActClass hierarchy itself.
CDA uses the notion of “entry” to describe any clinical statement within a document section, and uses “organizer” to name one of the clones in the clinical statement choice box whose ActClass values are limited to either “BATTERY” or “CLUSTER”. CDA never talks about “containers”.
Clinical Statement uses “organizer” to name one of the clones in the clinical statement choice box whose ActClass values are anything in the ActClassContainer hierarchy. Clinical Statement doesn’t talk about “entries” or “containers”.
The current ActClassContainer hierarchy looks like this:
- ActClassContainer - COMPOSITION - DOC - ENTRY - BATTERY - CLUSTER - EXTRACT - EHR - FOLDER - ORGANIZER - CATEGORY - DOCBODY - DOCSECT - TOPIC
- Submit a RIM Harmonization proposal to rename ActClassContainer codes as shown:
- ActClassContainer --> ActClassOrganizer - COMPOSITION - DOC - ENTRY --> GROUPER - BATTERY - CLUSTER - EXTRACT - EHR - FOLDER - ORGANIZER --> CONTAINER - CATEGORY - DOCBODY - DOCSECT - TOPIC
- The RIM Harmonization proposal would also change definitions accordingly
- A code is a meaningless mnemonic of a concept, and in itself has no semantics. Assigning a new code for an existing concept that lready has a code is (from a standardization standpoint) an unnecessary exercise. At most the description of the codes needs to be improved. Rene spronk 00:04, 2 October 2006 (CDT)
Jan 11, 2007 - While there is general support to change Entry to Grouper, there is concern with flipping Container and Organizer. The sense is that Container is more generic. We could consider changing the class name instead from Organizer to Container.
Recommended Action Items
Motion: Prepare a harmonization proposal moving the recommended list to Harmonization: Changes to the labels, only changes to definitions to adjust to the new labels but not the semantic definition of the concepts. Bob, Patrick
Richard Dixon-Hughes: Concern with 13606 nomenclature that is now not exactly in sync.
Abstain: 5, Against: 0, In Favor: 30
[Updated during September Meeting as the wiki was out-of-sync with the minutes]