CSCR-047 Make contextControlCode 0..1 Required on ActRels

From HL7Wiki
Jump to navigation Jump to search

Editing of Change Requests is restricted to the submitter and the co-chairs of the Clinical Statement Project. Other changes will be undone. Please add comments to the "discussion" page associated with this Change Request.

Back to Clinical Statement Change Requests page.

Submitted by: Rik Smithies Revision date: 12-Feb-2006
Submitted date: 12-Feb-2006 Change request ID: CSCR-047

Issue

Several act relationships in the pattern have attributes : contextControlCode – [1..1] Required.

(These are currently : sourceOf2, sourceOf1, component, precondition (from ObservationRange), precondition (from choice box), referenceRange.)

The NHS in the UK do not currently plan to use context conduction of acts across act relationships, and so don’t need these attributes.

However, as 1..1 Required, it is not possible for UK models to be compliant without including them. They must even be sent as as values in xml instances.

Recommendation

  • Relax these attributes to be 0..1 Required.

Rationale

This means the attributes must still be present in Clinical Statemtent compliant models, but need not be used, and can be missed out of instances. This will allow existing NHS messages to be compliant, but not allow models to ignore context conduction altogether.

Discussion

Noted there are problems with Act to Act participations

Recommended Action Items

Resolution

2 March 2006 1st AK, 2nd PM-J: Accept proposal. Against 0 Abstain 2 For 6. Approved. Hans Buitendijk, Isobel Frean, Andrew Perry, Rik Smithies; Patrick Mitchell-Jones, Austin Kreisler Heath Frankel, Patrick Lloyd

20 April 2006 CSP v0.2.3 updated; However, further discussion is required as the change as specified does not meet the requirement